トップ 差分 一覧 ソース 検索 ヘルプ PDF RSS ログイン

Flex

無料のswf(Flash)コンパイラ。
なにはともあれマニュアル類とリファレンスガイド。

ActionScriptデベロッパセンター
http://www.adobe.com/jp/devnet/actionscript.html
Adobe ActionScript3 リファレンスガイド
http://help.adobe.com/ja_JP/FlashPlatform/reference/actionscript/3/index.html
Flex3とFlex4の違い
http://www.adobe.com/jp/devnet/flex/articles/flex3and4_differences.html

インストール

インストールといっても解凍するぐらい。
まずJava Runtime Environment(JRE)が必要なので下記にアクセスし、インストールされているか、バージョンはいくつかを確認しておく。

How do I test whether Java is working on my computer?
http://java.com/en/download/help/testvm.xml

入っていないようなら先にJREのインストール。

>java -version
java version "1.8.0_66"
Java(TM) SE Runtime Environment (build 1.8.0_66-b18)
Java HotSpot(TM) 64-Bit Server VM (build 25.66-b18, mixed mode)

1.4.2以降ならOK。

下記よりFlex 3.x SDKをダウンロード。

Adobe - Flex 3:Flex Downloads
http://www.adobe.com/products/flex/flexdownloads/

Flex 3.4 SDKで約120MBのzipアーカイブになっている。

ダウンロード画面のStart Leaning Flexをクリックすると

Flex Developer Center
http://www.adobe.com/devnet/flex/

に行くが、いま見てもよくわからない(汗)。

flexとかのインストールドキュメントなどは

Adobe Flexリソース
http://www.adobe.com/support/documentation/jp/flex/

で、とりあえずc:\にflex_sdk_3.x.zipを解凍する。

C:\flex3

デバッグでtrace()を使ったときに、普通のFlash Player?では確認できないようなのでデバッグFlash Playerを入れる。

普通のかデバッグかの確認は、Flashが表示されるようなサイトで、Flashの上で右クリックし、ショートカットメニューに「デバッグ」項目があるかどうかで判断できる。

で、デバッグFlash Playerを入れるまえに、既存のFlash Playerは削除する必要があるので↓からアンインストーラをゲット。

TechNote
http://kb2.adobe.com/cps/141/tn_14157.html

uninstall_flash_player.exeを実行したら、一度再起動。

デバッグFlash Playerはflexに同梱されているので、OSにあわせたものをインストール。

C:\flex3\runtimes\player\10\win\Install Flash Player 10 ActiveX.exe
C:\flex3\runtimes\player\10\win\Install Flash Player 10 Plugin.exe

多分、ActiveXがIE系でPluginがMozilla系。
どちらもインストールしたらまた再起動。

インストールドキュメントにはここまでしか書いてないが、実際にはデバッグFlash Playerに対する設定ファイルが必要みたい。

ユーザのホームディレクトリにmm.cfgファイルを作成し

C:\Documents and Settings\user\mm.cfg

↓を記述しておく。

ErrorReportingEnable=1
TraceOutputFileEnable=1

詳しくは

デバッガ版の Flash Player の構成
http://livedocs.adobe.com/flex/3_jp/html/help.html?content=logging_04.html

xpでは↓の場所にflashlog.txtが作成される。

C:\Documents and Settings\user\Application Data\Macromedia\Flash Player\Logs\flashlog.txt

mm.cfgで

TraceOutputFileName=C:\foo\bar

のようにflashlog.txtの出力先を変えられるがFlash Player 9 Update以降はダメなのね(汗)。

サンプルの実行

samplesにexplorerサンプルとかいうのがあって、試すようにとインストールドキュメントに書かれている。
多分、試す必要はないと思うのだが、初めてなので試しておく。

xpではbuild.batを実行して待つだけ。

C:\flex3\samples\explorer\build.bat

結構時間がかかるのでしばらく休憩。

完了後、explorer.swfを実行すると各種サンプルとそのコードが確認できる。
かなり参考になるかも。

Hello World

これをやらなきゃ始まらないw

書き方としてはasとmxmlの2通りあるみたい。
↓はasタイプ。

package {

    import flash.display.*;
    import flash.text.*;

    [SWF(width="300", height="300", backgroundColor="#000000", frameRate=60)]

    public class HelloWorld extends Sprite {

        public function HelloWorld() {
            var textObj:TextField = new TextField();
            textObj.text = "Hello World";
            textOjb.autoSize = TextFieldAutoSize.LEFT;
            addChild(textObj);
        }

    }

}

上記をHelloWorld.asとして保存。
コマンドプロンプトより

C:\flex3\bin\mxmlc HelloWorld.as

としてHelloWorld.swfが作成されれば成功。

あとはコンパイラへパスを通せばコマンドラインからでもそれなりに使えると思うが、ここではFlashDevelopを使うことにするのでやらない。

FlashDevelop

テキストエディタでコード書いてコマンドラインからコンパイルしてもいいけど、便利そうな無料の統合環境?があるのでこれを使ってみることにする。

FlashDevelop
http://osflash.org/flashdevelop
FlashDevelop.jp
http://flashdevelop.jp/

現在のバージョンは3.0.5RTM。
動作には.NET 2.0 frameworkが必要なので、なければ先にインストールしておくこと。

FlashDevelopの初期状態は、エディタで日本語を入力すると文字化けする。

メニューの[Tools]-[Application Files...]よりSettings\Languagesとフォルダを開いて、AS3.xmlを

<use-styles>
    <style name="default" fore="0x000000" back="0xffffff" size="10" font="MS Gothic" />
:

のように、MS Gothicに変更する。

以前のバージョンでは[Tools]-[Program Settings]のUI Editor Fontで変更できたりしたみたいだが、バージョン毎にいじる場所が違う模様。

メニューの日本語化は

logicalyze::blog FlashDevelop 3.0.5RTM の日本語化ファイル
http://www.logicalyze.net/blog/?p=3151

で配布されている

をSettingsに放り込めばOK。

FlashDevelopから先に用意したFlexを利用するにあたり、その場所を設定する必要がある。

[Tools]-[Program Settings...]よりAC3Contextより

Default Flash Version     10
Flex SDK Location         C:\flex3

のように、Flexのほうの状態に合わせる。

同じく[Tools]-[Program Settings...]のFlashViewerより

Movie Display Style       popup

実際にプログラミングする際は

[Project]-[New Project...]よりAS3 Projectを選択。

あとプログラム上で

[SWF(backgroundColor="#000000", width="400", height="400", frameRate="60")]

とした場合、backgroundColorは反映するが、widthやheightは変更できないみたいなので、[Project]-[Properties...]で変更する。

外部のライブラリを利用する場合、プロジェクト単位でよければlibに置いておけばよさそう。
[Project]-[Properties...]のClasspathsよりlibを追加しておけばOK。

すべてのプロジェクトで共通に使いたいライブラリは

C:\Program Files\FlashDevelop\Library\AS3\classes

に置けば、パスを通す必要もなさそう。

お気に入りライブラリ

緩急つけて動かしたいときに

tweener
http://code.google.com/p/tweener/

グループ単位でロードしたいときに

bulk-loader
http://code.google.com/p/bulk-loader/

3D描画に

papervision3d
http://code.google.com/p/papervision3d/

画像ロードなどの待ち表示に

Web 酒 肴:[Flex][ActionScript]くるくる回るローディング(読み込み中)画像をFlex
http://blog.obanet.jp/?p=283